1988 BII Problems

Results 1 to 14 of 14
  1. #1

    Join Date
    Jul 2006
    Posts
    413

    1988 BII Problems

    My problem started with my starter relay clicking after I have turned the engine off, lasted all of 5 seconds. So I buy a new stater relay, same thing, than it started to last longer, 10 - 20 seconds and my fuel pump would run at the same time the relay was ticking... So fuel pump would run with the relay, (same amount of time) when the relay stoped clicking the pump stoped. (Main Fuel Pump on the frame rail)

    Than driving home my engine light comes on and the truck dies out. (In the snow storm we had last week!) I pull over turn it off, and it starts right back up, and runs fine. 15min later same thing happens. The truck starts to not run as long before the engine light comes on. The truck WOULD run wile the engine light was on, but VERY RUFF! Now I cant really get it started at all... It will start for maybe 5 seconds than just die right out. Any ideas what this may be?
    Ive been told either Computer, key relay...
    Any ideas?

    Thanks

  2. Remove Advertisements
    BC4x4.com
    Advertisements
     

  3. #2

    Join Date
    Jul 2006
    Posts
    413

    Re: 1988 BII Problems


  4. #3

    Join Date
    Dec 2002
    Posts
    39

    Re: 1988 BII Problems

    i`d do some trouble shooting my first guess would be ignition so i`d try by shutting the engine off and while it is clicking pull the plug on the harness going to it and see if it stops........if that dont work go to the next suspect piece and do the same...... im not a mechanic but thats where i`d start

  5. Remove Advertisements
    BC4x4.com
    Advertisements
     

  6. #4

    Join Date
    Jul 2006
    Posts
    413

    Exclamation Re: 1988 BII Problems




    I cannot find this wire connector harness on the steering column... Find the ones for either light and the blinker wipers etc... Nothing from the ignition except one little black wire that goes under the dash


    I got the part for $24 or so.
    I got my dash/ steering column apart, now I thought for some reason this thing would be right beside the keys.... But its not as far as I can tell. I have no idea where it is on my truck. Where and the hell is it!!! Its not in my book either, well I cannot find it in there. I can find how to take the ignition out but I cannot find this at all! Iam talking about the switch/plug in the pic above
    Its never as easy as it sounds!!!!



    Now I just realized that my 88 BII has a "newer style" dash. Like from a 1989 and up. I asked for a 1988 electrical ignition switch, now would it be different for the old style dash? Or does it matter at all? It is tilt steering.

  7. #5
    Registered User
    Join Date
    Jun 2001
    Location
    Blaine WA.
    Posts
    219

    Re: 1988 BII Problems

    It is on top of the steering column, right above your feet. Probly have to unbolt the column from the dash (2 bolts) and push it down to get to it.
    86 samurai wheeler
    88 samurai stocker
    94 sidekick daily driver

  8. #6

    Join Date
    Jul 2006
    Posts
    413

    Re: 1988 BII Problems

    Quote Originally Posted by LT. LARRY View Post
    It is on top of the steering column, right above your feet. Probly have to unbolt the column from the dash (2 bolts) and push it down to get to it.
    is it in a different place on the older BII's?
    I found a wright up and it still shows it by the keys.,.. Deffently not there. But thanks for the info, Ill check it out when I get home. Lets hope the rain will stop for a min!

  9. #7

    Join Date
    Jul 2006
    Posts
    413

    Re: 1988 BII Problems

    found it thanks.
    it was a different plug, went and got a 89 one.... still not the problem. Now new computer

  10. #8
    Registered User Captain Air Time's Avatar
    Join Date
    Nov 2000
    Location
    Campbell River
    Posts
    1,469

    Re: 1988 BII Problems

    bad grounds. battery, body, frame.
    Taste the High Speed Dirt!
    98 Exploder v3.0

  11. #9

    Join Date
    Jul 2006
    Posts
    413

    Re: 1988 BII Problems

    Changed the computer and that was also not the problem.... I do have spark.
    What other ground should I check other than the batt.?
    I put new plugs in, and there is fuel getting to the plugs. Now I took out a plug and turned the engine over and there was a spark, but it was like one a second. Should it have more spark than that?

    Also where is the fuel pump relay on this thing???

    And can my truck run with out a inertia switch?
    Last edited by Limited; January 20th, 2007 at 05:39 pm.

  12. #10
    Registered User Captain Air Time's Avatar
    Join Date
    Nov 2000
    Location
    Campbell River
    Posts
    1,469

    Re: 1988 BII Problems

    Quote Originally Posted by Limited View Post
    Changed the computer and that was also not the problem.... I do have spark.
    What other ground should I check other than the batt.?
    I put new plugs in, and there is fuel getting to the plugs. Now I took out a plug and turned the engine over and there was a spark, but it was like one a second. Should it have more spark than that?

    Also where is the fuel pump relay on this thing???

    And can my truck run with out a inertia switch?
    It will run without the inertia switch if you short the plug, or just twist the wires together. it is basically an on/off switch inline with your fuel pump.

    Is your in-tank (low pressure pump) working? sounds like it might be starving for fuel.
    Taste the High Speed Dirt!
    98 Exploder v3.0

  13. #11

    Join Date
    Jul 2006
    Posts
    413

    Re: 1988 BII Problems

    ahhh found what was actually clicking!!! This whole time I thought it was my starter relay, but I found it was a different relay thats mounted under the main fuse box... Ill replace it and see what happens..
    Last edited by Limited; January 21st, 2007 at 03:36 pm.

  14. #12

    Join Date
    Jul 2006
    Posts
    413

    Re: 1988 BII Problems

    Okay I replaced it, still no fix. So as far as I know it is my fuel pump relay that is clicking. I had it in my hand when it was clicking. Put a new one in and the same thing.... Now I found this other relay that was right beside it, not sure if its either the PCM Power relay or the heater blower relay... but it was hot just from me trying to start the engine.
    Any ideas on what one is what?
    I know the gray/black is fuel pump... As far as I know.




  15. #13

    Join Date
    Jul 2006
    Posts
    413

    Re: 1988 BII Problems

    alright I got it to start with no problems now. First it ran sooooooooooooooooo bad, missing, blowing black smoke like crazy! So I took the new computer I just put in and put my old one back in, and it works alot better now. No engine light or anything. But now it still doesent run so good, when I crank the wheel and press the break it dies out, just feels weak as hell. And it sputters all the way down the street. But no engine light at all.
    Any idea why its runnung like poop? I did put new plugs in, but think maybe when it was running with the other computer it could have fouled them?

  16. #14

    Join Date
    Jul 2006
    Posts
    413

    Re: 1988 BII Problems

    fixed
    thanks for the info

    Fouled my plugs when the wrong computer was in,
    new plugs fixed it.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •